Reducing tcp_time_wait_interval

Category: General 12 years ago
I'm working with Solaris 8 and ASE 12.0. I have a situation in which
clients connect and disconnect frequently from the dataserver, thus
leaving many TCP connections in the TIME_WAIT state. Sometimes
there are so many thousands of connections in the TIME_WAIT state
that I can't open new connections to the dataserver.

There is a tcp_time_wait_interval set to a default of 240000 milliseconds.
According to documentation I found, it is stated that "... the length of
time
for this state is 240 seconds, which is to allow for any duplicate segments
still in the network from the previous connection to expire."

On tests that I have done, reducing the tcp_time_wait_interval to a
smaller number releases these TCP connections in TIME_WAIT state.

Does anybody know the implications of reducing the tcp_time_wait_interval?
Is it safe to do so?

Thanks,
Victor Diaz
Like it on Facebook, +1 on Google, Tweet it or share this topic on other bookmarking websites.
  • Re: Reducing tcp_time_wait_interval

    by » 12 years ago


    Hasta donde yo recuerdo el parámetro de TCP que interviene en esto es el tcp_keep_alive_interval, intenta con éste y nos comentas.

    Y que quieres decir con "I can't open new connections to the dataserver", tal vez no tienes configurado el parámetro "number of user connection" a un valor considerable apra tu ambiente.

    Checa estos puntos y nos comentas.

    Saludos

    COM

    DBASupport Team


  • Re: Reducing tcp_time_wait_interval

    by » 12 years ago


    hola, si tenes el ASE corriendo sobre Linux, en el archivo /etc/sysctl.conf deberias setear algo como esto:

    #KeepAlive setting for Sybase
    net.ipv4.tcp_fin_timeout = 40
    net.ipv4.tcp_keepalive_time = 3600
    net.ipv4.tcp_keepalive_intvl = 10
    net.ipv4.tcp_keepalive_probes = 5

    #TCP tunning for Sybase
    net.ipv4.tcp_syncookies = 0
    net.ipv4.tcp_sack = 0
    net.ipv4.tcp_timestamps = 0
    net.ipv4.tcp_window_scaling = 0

    Saludos.

You do not have permissions to reply to this topic.
Powered by CjForum